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Adobe provides a consistent interface through-
out its products. If you’ve used Photoshop or

Illustrator, many of the tools in After Effects
will be familiar to you. On the other hand,

After Effects is based on some concepts
and features that might be new to you,
and for this reason the interface is
distinct as well.

Because the program requires
assets, such as movies, sounds,
and images (called footage), it has
a Project window that stores all
these types of items. It also has a
Timeline window for setting up the
motion for your moving images and 

a Composition window that acts as 
a stage where you can build, preview,

and edit your projects. When working 
in After Effects, you’ll primarily use these

three windows. This chapter gives you a
quick overview of these windows and walks

you through a simple project so you can see
how the interface changes in relation to your con-

tent. Other chapters will go into much more detail. As
you’ll see later, the After Effects interface gets a lot deeper

when you start to build projects and moving pictures.

2.
Interface

| First View | Project Window | 

| Composition Window | Timeline | 

| Time Controls Palette | Audio Palette | Info & Tool Palettes |

| Shortcut Keys | Using the Interface |

chap_02

After Effects 6 
H•O•T CD-ROM
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First View of After Effects

This is what you’ll see the first time you open After Effects and create a new project. On Mac, the
windows and palettes that open by default include the Project window, the Tools palette, the Info and
Audio palettes, and the Time Controls and Effects palettes. In Windows, the default palettes are Tools,
Info and Audio, and Time Controls and Effects. None of these windows and palettes do anything until
you bring content such as movie footage, Photoshop files, Illustrator files, or other supported document
types into the program. You’ll learn how to bring in footage very soon!

Tips appear by default each time the program opens. Reading them can be incredibly useful, and you
can cycle through more than one tip by clicking the Next Tip button. If you don’t want to see tips on
startup, uncheck the Show Tips at Startup check box, and they will disappear. You can always get
them back by choosing Help > Tip of The Day.
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The Project Window
After Effects is different from many other programs that you might be familiar with because it uses
something called the project to organize content and store the settings you create to produce anima-
tion and output audio. When you bring artwork into Photoshop, for example, that artwork is saved with
the Photoshop document. The project file in After Effects is quite different because the project file only
maintains pointers to whatever artwork you import. For this reason, After Effects project file sizes are
quite small. They are also incredibly important because without a project, you can’t work in After Effects
at all.

The Project window is one of the three primary windows you use in After Effects. Think of it as where
you store all the media you’ll be working with—from still images to video footage to sounds. The word
footage is an umbrella term for most media, even still images or audio. Importing or adding footage
into your project creates references in the Project window. This means that the footage isn’t actually
copied into After Effects; instead, the project maintains pointers to where the footage resides on your
hard drive.

Whenever you open a new After Effects project, a new empty Project window appears. When you
import footage, it appears in the Project window. When you save your work, you save a project file,
hence the file extension .aep (After Effects Project). The project file memorizes all kinds of things,
including, but not limited to, the footage references of content you’ve imported. Think of After Effects
as “linking” to the footage, whereas programs such as Photoshop or Illustrator “embed” content. This
process will become much clearer as you work through the book.
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Here’s an example of a Project window that is filled with content. In order to see all this content, you
would need to expand the Project window by dragging on its lower-right corner. Footage assets and
compositions show up as a list in the Project window. This window can be stretched wider by drag-
ging on the lower-right corner.

Panels in the Project window allow you to view details about your footage or composition. A composi-
tion in After Effects is a type of file that you will learn how to create in which you combine all your layers
of content and set it to animate over a Timeline. You’ll learn all about compositions in Chapter 4, “The
Composition”. Panels form columns of information showing the name, label, size, type, file path, com-
ments, date, and duration of each item. You can make a panel wider or narrower, and you can rearrange
the order of panels simply by clicking and dragging the panel you want to move.

After Effects 6 H•O•T | 2. Interface

Panels
Project Options menu

Footage assets

Compositions
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The Composition Window
The Composition window is the second of the three primary windows. Whereas the Project window
contains a list of files and folders, the Composition window is where the visual preview or playback of
your project appears. It’s the equivalent of a screen area in a movie theater, except that you can have
multiple compositions within a single project. A project is more like the movie theater complex where
they are showing lots of movies, and each movie is represented by a composition! That’s a silly analogy
perhaps, but you are not limited to one composition per project—you can have hundreds of composi-
tions per project, in fact. You can even nest compositions within compositions. The Composition win-
dow does not appear until you create a composition. You create a composition file from the Project
window. You will see how to open a composition later in this chapter.

The Composition window is the equivalent of a stage or movie screen. It is where the visual preview
of your work appears. The Composition window does not appear until you create and/or open a com-
position. You’ll learn how to do this later in this chapter. You’ll learn more about the features of this
window in Chapter 4, “The Composition.”
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The Timeline Window
The Timeline window is the third primary window you use in After Effects. Like the Composition window,
the Timeline window does not appear until you have opened a composition. It will be missing from your
screen until you do this in Exercise 1, later in this chapter.

The main function of the Timeline window is to give you the ability to control time relationships between
the various footage elements in your composition.

Footage elements are arranged in layers in the Timeline window. The length of each layer represents
its duration in time. You can cause each layer to start or stop (be visible or invisible) at any point in
the composition by adjusting it in the Timeline. You will learn more about the Timeline in Chapter 5,
“Timeline, Keyframes, and Animation,” as well as throughout the entire book.

Palette Organization
The palettes in After Effects can be pulled apart, reorganized, and restored easily. What distinguishes 
a palette from a window? A palette includes a tab; a window does not. This tab can be used to view
or move a palette.

For example, the following palette group opens by default in the After Effects interface: Tools, Info,
Audio, Time Controls, and Effects. If you select Window > Tools, all the palettes open that are con-
nected together with Tools (Info, Audio, Time Controls, and Effects). If you separate Tools away from
the group, it can be accessed independently.

After Effects 6 H•O•T | 2. Interface
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Palettes can be separated and re-attached by dragging them on and off palette groupings by their
tabs. To reset all your palettes to their default positions (which comes in handy if your screen gets
too chaotic!), choose Window > Reset Palette Locations.

Time Controls Palette
The Time Controls palette allows you to preview the compositions you create as moving images. You
can play back the entire piece or select a specific frame.

The Time Controls palette: A. First Frame B. Previous Frame C. Play/Pause D. Next Frame E. Last
Frame F. Audio G. Loop H. RAM Preview I. Shuttle J. Jog K. Time Indicator. These terms are defined
in Chapter 5, “Timeline, Keyframes, and Animation.”

2. Interface | After Effects 6 H•O•T
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Audio Palette
On Mac, by default, the Audio palette is located in the same window as the Time Controls palette. 
On Windows, it is grouped with the Info palette. You can separate the Audio palette into its own
window by clicking and dragging the Audio tab.

The Audio palette: A. Level controls B. Level units C. Audio Options menu D. Level values E. Audio
Clipping warning icons F. VU (Volume Unit) meter. The audio level controls allow you to set the
volume for each audio layer. The VU meter displays audio levels during playback. You will learn 
about these terms in Chapter 17, “Audio.”

Info Palette
The Info palette gives you information about images in the Composition window.

The Info palette offers color, alpha transparency, and coordinate information. You’ll learn more about
these topics throughout the book.
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Tools Palette
The Tools palette provides a number of tools for drawing in the Composition window or for selecting
elements and objects.

The Tools palette: A. Selection B. Rotation C. Orbit Camera D. Hand E. Zoom F. Pan Behind 
G. Brush (new!) H. Clone Stamp (new!) I. Eraser (new!) J. Mask K. Type (new!) L. Pen. Note 
that some of these tools are new and reflect the capability of After Effects 6.0 to paint and type
directly (rather than using external programs). You will learn about these different tools in 
future chapters.
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Shortcut Keys
There are many shortcut keys in After Effects, and all of them are listed in your program manual. The
following chart lists the ones we find most useful. The book will refer to specific shortcut keys through-
out the chapters as you encounter reasons to use them, so don’t spend too much time memorizing
them here. Consider copying this list and taping it to your monitor! This list will prove invaluable to 
you after you have learned the program.

After Effects 6 H•O•T | 2. Interface

Shortcuts in After Effects

Command Mac Windows

Import file Cmd+I Ctrl+I

Project settings Cmd+Option+Shift+K Ctrl+Alt+Shift+K

Suspend window updates Caps Lock Caps Lock

Display/hide palettes Tab Tab

Step forward one frame Cmd+right arrow Ctrl+right arrow

Step backward one frame Cmd+left arrow Ctrl+left arrow

Start/pause playback Spacebar Spacebar

RAM preview 0 on numeric keypad 0 on numeric keypad

Nudge layer one pixel in specific direction Arrow key Arrow key

Select next layer back Cmd+down arrow Ctrl+down arrow

Select next layer forward Cmd+up arrow Ctrl+up arrow

Zoom in . (period) . (period)

Zoom out , (comma) , (comma)

Zoom in and resize window Option +. (period) Alt + . (period)

Zoom out and resize window Option + , (comma) Alt + , (comma)

Switch from Selection tool to Pen tool Hold down Cmd Hold down Ctrl
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Using the After Effects Interface

This exercise introduces you to the three primary windows in After Effects and lets you explore the
basic functionality of each. An After Effects project file has been prepared for you in advance that 
you will open in this exercise.

1.

1. Launch After Effects and open interface.aep from the chap_02 folder that you have trans-
ferred to your hard drive from the H•O•T CD-ROM.

Note: It’s very important that you transfer these files to your hard drive so that you can edit
them in the future.

Notice that the Composition window and the Timeline window are open. Inside the
Composition window, you’ll see a preview of some artwork. Inside the Timeline window,
you’ll see a number of layers with a lot of settings. These settings will be described in 
detail in later chapters.

Note: If your windows are disorganized because of moving them in the last chapter, choose
Window > Reset Palette Locations.

2. Interface | After Effects 6 H•O•T
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2. In the Time Controls palette, locate the Play button and click it. You can accomplish the same thing
by pressing its shortcut key, the spacebar.

3. Watch the animation play as a preview in the Composition window. Click the Play button again in
the Time Controls window or press the spacebar to pause the animation.

After Effects 6 H•O•T | 2. Interface
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4. In the Timeline window, locate the Current Time Indicator. Drag the Current Time Indicator left
and right, and observe how its position affects the preview in the Composition window. This process 
is also know as “scrubbing” in the video editing industry.

Notice the green line in the Timeline window? This appears as After Effects “renders” the content 
to preview and play back. This green line will become a familiar cue to you as you work through the
book’s exercises. As you add things such as Effects and 3D, playback can take longer because it
takes longer to render the footage. It’s helpful that you can position the Current Time Indicator to a
specific frame, because sometimes you want to check a certain part of the Timeline but don’t want 
to watch the playback of the entire composition.

5. Click the Close button to close the Composition window. Note: The Close button for Windows
users is in the upper-right corner of the Composition window.

Observe that the Timeline window also closes. Without an open composition, the Timeline will not
appear. To get the Timeline and the Composition windows back, simply double-click interface comp
in the Project window.

2. Interface | After Effects 6 H•O•T
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6. Close the project and don’t save your changes. You can either quit After Effects or leave it 
open for the next chapter. You might want to choose Window > Reset Palette Locations to 
make sure that your palette positions in After Effects look the same for future chapters as they 
do in the book’s examples.

Congratulations! You’ve completed your first exercise, and you got a good look at the After 
Effects interface. Best of all, you’ve been able to interact with After Effects and see results 
firsthand. In the next chapter, you’ll learn more of the details involved in creating After Effect 
projects. Soon you’ll be making your own compositions, making them move, and saving movies. 
Keep reading on!
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